Wikimedia Developer Support

Cant able to run ffmpeg with VideoCutTool in wikimedia toolforge

I’m working on VideoCutTool as a part of GSoC 2019, our project is almost done, we hosted our tool-back-end in toolforge, here https://tools.wmflabs.org/video-cut-tool-back-end/

This server has ffmpeg installed, we implemented video encodings using ffmpeg, This tool is working fine locally, I along with my GSoC mentor tested this several times in several ways in a server, always we are facing the same error [1][2][3][4]

Error: ffmpeg not found.

We also tried use ffmpeg to test a video rotation in the server using CLI in toolforge server this works fine, but if we run the tool this is failing (ffmpeg not found)

[1] https://ibb.co/RTLMnN8
[2] https://ibb.co/dLmYFvH
[3] https://ibb.co/1mZxFNF
[4] https://ibb.co/Xt3MKmv

VideoCutTool:
[1] https://phabricator.wikimedia.org/T220228

Github:
[1] front-end: https://github.com/gopavasanth/video-cut-tool-front-end/
[2] back-end: https://github.com/gopavasanth/video-cut-tool-back-end/

In toolforge:
front-end: https://tools.wmflabs.org/video-cut-tool-front-end
back-end: https://tools.wmflabs.org/video-cut-tool-back-end

Any ideas/suggestions please ?

1 Like

How is ffmpeg installed? Can the k8s pod see it?

If you get a shell pod, can you use ffmpeg?
As the tool account try webservice - - backend=kubernetes node shell. What is the output to which ffmpeg there?

Hello Chico,

I don’t remember how I installed ffmpeg,
I started this tool by using webservice --backend=kubernetes node10 start

This is the following result I got: https://ibb.co/FB4jTnj