Cant clone the gerrit.wikimedia.org repositories

mediawiki

#1

Hi all, I’m having troubles cloning this repository gerrit.wikimedia.org:29418/mediawiki/extensions/examples.git and every other repo and I’ve tried $ git clone ssh://didi@gerrit.wikimedia.org:29418/mediawiki/extensions/examples.git but I get error message fatal: could not create work tree dir ‘examples’: Permission denied .


#2

Presumably the user didi does not exist. Either register it or clone anonymously. The repo page has sample commands.


#3

Thanks for the response.
i have already registered the username didi but it is still not working. I have also tried to clone it anonymously but it keeps giving the same error fatal: could not create work tree dir 'core': Permission denied Here is a picture of my username didi which is registered


#4

Sorry, I replied without reading in full. fatal: could not create work tree dir ‘XXX’: Permission denied is a client-side problem: you are trying to clone but you don’t have write permissions for the directory you are cloning into.


#5

How can I get write permissions for the directory? I am trying to apply to be an intern in this organisation for outreachy. I want to work on this project https://phabricator.wikimedia.org/T204612
but I dont know if I am taking the right steps. Kindly help me out with that


#6

Something like chmod u+w <directory> (where u+w stands for “writable to the user who owns it”) but it’s probably easier if you just do the cloning in your home directory.


#7


It is working now. Thank you so much for your help.


#8

Are you sure that your local user account on your machine has write permissions for the local folder/directory on your machine in which you want to save the clone of the git repository?

Edit: Ignore this comment - I obviously did not scroll down to the bottom of this page to see that the problem is already solved.