Wikimedia Developer Support

Error when Visiting Mediawiki Special:SpecialPages

I Installed Mediawiki using the vagrant install, when I try navigating to the Special:SpecialPages,
I get the error in the screenshot below

Any Idea how I can fix this?

1 Like

I suspect it’s due to incompatible versions of MediaWiki core and some extension or skin… I think the ObjectFactory / special page registration system changed a lot in MediaWiki 1.34, maybe you’re using a MediaWiki version of 1.34 or later with an older extension/skin, or vice versa?

1 Like

Maybe you need to update your php by executing php udpate.php in the maintenance folder of the core?

2 Likes

Works like a Charm! Since I am using the Vagrant install, running vagrant up then the update command vagrant git-update saved the day, thanks!

1 Like