Wikimedia Developer Support

Problems with email forwarded to a mirrored mailing list

This might pose a problem as well:

I wonder whether forwarding an email to mediawiki-l will reproduce this problem or not.

See the reply received. Forwards do work, but they may appear in a way that you don’t expect. I still think we should try a forward to a mirrored mailing list, because there the behavior might be just replicating the email as is.

We should probably set up a test mailing list instead of spamming real ones or just waiting for someone to fortuituously doing the same thing we want to test.

Good idea, obviously. I am currently too overbooked. If someone else wants to go ahead, please by all means. :slight_smile:

In order to test this mirror, you need to register to

We have a problem with forwarded emails indeed.

It’s strange. I have tried forwarding the same email from the same email client (GMail) to another test instance (private) and there it works. The settings are the same. The difference is that here we are going through a mailing list and a category in mailing list mode, while there we post directly to a group.

I’m going to sleep. If nobody has got a brilliant idea in the next hours, I will ask upstream.

Is the discourse list text-only? I imagine that would change the behavior pretty fundamentally.

Good point. Admin rights requested to check settings and play with them.

Hi Quim. You are now admin on the discourse mailing list. Have fun! Ad

1 Like

And thanks for the nice words and compliments. And thank you for reviving the efforts. I have been dormant on the efforts a while. Greetings, Ad

1 Like

The list was text-only indeed, and now it is set to preserve MIME. Still, forwards will not get through.

The only differences I can see with the other installation where forwards seem to work just fine are:

  • That instance is up to date, this one is one beta release behind. I will upgrade tonight and try again.
  • That instance receives emails as messages, and here they are topics. If upgrading doesn’t work, I will replicate the mailing list mode there to see what happens.

Maybe the ---------- Forwarded message ---------˙ line gets mistaken for the–` signature separator?
Although looking at the code it shouldn’t be happening.

But then that mistake could be reproduced in this other Discourse instance…

I have upgraded our instance, and nothing.

I will try to reproduce this problem in a mailing list mirror category in this other instance. Perhaps it is a “mailing list mirror” bug.

Apparently they use this other gem now, which does remove forwarded messages. (Of course that still doesn’t explain why it’s only happening on some sites.)

After several tests, I think the problem is that “Mailing list mirror” is trimming forwards thinking they are signatures. I actually think that the trimmer should be disabled in a mirror, to assure that the content effectively mirrors the mailing list.

There are fairly specific rules for forwarding, it’s not getting confused with signatures.

Dashes are treated as a delimiter and everything after the first delimiter is removed (which seems like a pretty terrible idea).

Feature requested: