Some tests blocked my test job

phpunit

#1

When I running php tests/phpunit/phpunit.php, the process is stuck at some point, and it is not an accident but a necessity occurred.

$ php tests/phpunit/phpunit.php
Using PHP 7.2.9
PHPUnit 6.5.13 by Sebastian Bergmann and contributors.

...........................................................    59 / 20071 (  0%)
...........................................................   118 / 20071 (  0%)
...........................................................   177 / 20071 (  0%)
...........................................................   236 / 20071 (  1%)
..SSS.......................FFFSSSSSSSSSS..................   295 / 20071 (  1%)
....................................F......................   354 / 20071 (  1%)
..........................................................S   413 / 20071 (  2%)
SS.........................................................   472 / 20071 (  2%)
...........................................................   531 / 20071 (  2%)
...........................................................   590 / 20071 (  2%)
...........................................................   649 / 20071 (  3%)
...........................................................   708 / 20071 (  3%)
...........................................................   767 / 20071 (  3%)
...........................................................   826 / 20071 (  4%)
...........................................................   885 / 20071 (  4%)
...........................................................   944 / 20071 (  4%)
...........................................................  1003 / 20071 (  4%)
...........................................................  1062 / 20071 (  5%)
.......

Same test running on my linux system looks good, and now I using Windows then occurred this issue. This makes me guess that something is blocking the process, but I don’t know how to find it. Can I find a blocked test?


#2

If you run PHPUnit with --verbose and/or --debug it should print the individual test names.


#3

Thanks you, I use --debug option to found the blocker – WfShellExecTest::testT69870(). But I don’t know why this test make the job infinite waiting.


#4

Can you mention this, along with your system details, in T69870?


#5

Already leave comment.